libstdc++.so.6 nachinstallieren... Wie??

  • Ich versuche gerade einen FarCry-Server aufzusetzen, was sich aufgrund der fehlenden lib-Datei als schwieriger herausstellt, als ich dachte...


    Ich habe versucht die Datei über yast zu finden. Dort zeigt er mir aber nur die Version libstdc++.so.3.3.3 an.
    Wenn ich versuche die upzudaten, klappt das leider nicht. Es bleibt bei der Version 3.3.3


    Hab mich auf der Seite rpmseek mal umgeschaut, doch da habe ich keine passende lib-Datei gefunden. Außer welche für Debian.
    Brauche die Datei für die i386-Architektur. Kann ich die auch unter Suse benutzen??


    Dazu kommt, dass alle Downloadlinks scheinbar gar nicht funktionieren. Ich habe mal versucht die Datei: libstdc++6_3.4.3-6_i386.deb herunterzuladen, um mal zu testen, ob ich diese installieren kann, doch ich bekomme nur Fehlermeldungen über nicht vorhandene Verzeichnisse auf den Servern...


    Irgendwie habe ich aber auch Sorge, dass ich mir mit der falschen lib mein System zerhaue.


    Wäre nett, wenn mir da einer weiterhelfen könnte.


    Danke

  • Hi Bobby,


    hab mich genau an deine Anleitung gehalten:



    Hat auch funktioniert so weit, doch bis auf Version 3.3.3 konnte ich nur updaten.
    Wenn ich aber über "locate" suche, findet er mir im Verzeichnis: usr/lib
    diese lib-Datei: libstdc++.so.5
    Aber die finde ich über yast so nicht...
    Auf rpmseek.com habe ich auch gesucht, aber ebenso keine Version 6 für SUSE 9.1 und Architektur i386 gefunden...


    Zudem sind das rpm-Pakete die ich irgendwie noch installieren muß. Dachte, es wäre einfacher, wenn ich einfach die lib-Datei bekommen und in das Gameverzeichnis stecken könnte... Oder funktioniert das nicht??