Sakuraza Anfänger
  • 117
  • Mitglied seit 17. Oktober 2005
  • Letzte Aktivität:

Beiträge von Sakuraza

    Thread kann geschlossen werden...


    Habe die Serverdatein nach mehrmaligen hochladen in verschiedenen Ordnern getestet und jetzt funktioniert er endlich :) irgendwo war da anscheinend ein Fehler enthalten???
    Aber nun freu ich mich über etliche Runden TMN.. :D


    Grüße
    Sakuraza

    Hallo zusammen,


    ich habe ein "kleines" Problem mit meinem TMN Server... es kommt immer folgende Fehlermeldung bis der Prozess von selbst abbricht oder ich ihn kill. Den Server starte ich im screen mit dem Befehl
    ./TrackManiaServer /game=nations /internet /game_settings=MatchSettings/Internet/Eigene.txt /dedicated_cfg=dedicated.cfg



    Meine Log:


    [2006/08/12 04:16:02] Initializing...
    [2006/08/12 04:16:02] Configuration file : dedicated.cfg
    [2006/08/12 04:16:02] Loading system configuration...
    [2006/08/12 04:16:02] ...system configuration loaded
    [2006/08/12 04:16:02] Loading cache...
    [2006/08/12 04:16:02] ...OK
    [2006/08/12 04:16:02] Listening for xml-rpc commands on port 5000.
    [2006/08/12 04:16:03] Couldn't stat
    '/srv/www/htdocs/web3/TmDedicatedServer/GameData/Tracks/Campaigns///////My Campaigns'
    [2006/08/12 04:16:03] Couldn't stat
    '/srv/www/htdocs/web3/TmDedicatedServer/GameData/Tracks/Campaigns///////My Campaigns'
    [2006/08/12 04:16:03] Couldn't stat
    '/srv/www/htdocs/web3/TmDedicatedServer/GameData/Tracks/Campaigns///////Downloaded'
    [2006/08/12 04:16:03] Couldn't stat
    '/srv/www/htdocs/web3/TmDedicatedServer/GameData/Tracks/Campaigns///////My Campaigns'


    Meine dedicated.cfg:


    <?xml version="1.0" encoding="utf-8" ?>


    <dedicated>
    <authorization_levels>
    <level>
    <name>SuperAdmin</name>
    <password>****</password>
    </level>
    <level>
    <name>Admin</name>
    <password>****</password>
    </level>
    <level>
    <name>User</name>
    <password>****</password>
    </level>
    </authorization_levels>

    <masterserver_account>
    <login>****</login>
    <password>****</password>
    <nation>GER</nation>
    </masterserver_account>

    <server_options>
    <name>The Edge</name>
    <comment></comment>
    <max_players>6</max_players>
    <password>ladida</password>
    <max_spectators>0</max_spectators>
    <password_spectator></password_spectator>
    <ladder_mode>forced</ladder_mode> // value between 'inactive', 'normal' and 'forced' (or '0', '1', '2')
    <enable_p2p_upload>True</enable_p2p_upload>
    <enable_p2p_download>True</enable_p2p_download>
    <callvote_timeout>60000</callvote_timeout>
    <callvote_ratio>0.25</callvote_ratio>
    <allow_challenge_download>True</allow_challenge_download>
    </server_options>

    <system_config>
    <connection_type>DSL_16384_4096</connection_type>
    <server_port>2350</server_port>
    <server_p2p_port>3450</server_p2p_port>
    <client_port>0</client_port>
    <xmlrpc_port>5000</xmlrpc_port>
    <xmlrpc_allowremote>False</xmlrpc_allowremote> // if you specify an ip adress here, it'll be the only accepted adress. this will improve security.
    <bind_ip_address></bind_ip_address>
    <force_ip_address></force_ip_address>
    <use_proxy>False</use_proxy>
    <proxy_login></proxy_login>
    <proxy_password></proxy_password>
    <blacklist_url></blacklist_url>
    </system_config>
    </dedicated>



    Ich habe alles nach Anleitung gemacht.
    Den TMN Ordner hochgeladen, die neuste Serverversion (TmDedicatedServer_2006-05-30.tgz) die ich fand hochgeladen und entpackt etc... Die Ordner sind alle vorhanden und ich weiß jetzt ehrlich gesagt nicht mehr weiter.. nachdem ich nun öfters gegooglet hab und leider nichts fand, hoff ich doch das ihr mir helfen könnt.


    Danke schonmal!


    Womöglich liegt es auch an der Uhrzeit, dass ich den Fehler nicht finde ^^


    MfG
    Sakuraza